Monthly Archives: September 2017

SmarterMail browser requirements

With the upgrade to Smartermail the web interface has been changed significantly. Below are the browser requirements should you need to access via webmail. Desktop SmarterMail is fully supported by any modern and updated desktop browser. Minimum versions supported: Google … Continue reading

Posted in Email Support | Leave a comment